ServiceDispatch API – Intermittent Webservice Issues (Monitoring)

Incident Report for ServicePower

Resolved

This incident has been resolved.
Posted Dec 08, 2025 - 11:50 UTC

Monitoring

Earlier this morning, we identified an issue where Webservices were not responding as expected following the recent product release. Our team has implemented a fix, and the system is now fully stable.

We will continue to monitor performance closely over the coming hours and do not anticipate any further disruptions.

Thank you for your patience and understanding.
Posted Dec 05, 2025 - 13:36 UTC
This incident affected: Dispatch-US (Dispatch-US - Application Services).