EU PROD – Service Disruption (FSS)

Incident Report for ServicePower

Resolved

The issue affecting the ServicePower EU (FSS) platform has now been resolved.

URL: https://fss.servicepower.eu/
Service functionality has been fully restored and is operating normally.

Summary:
Systems are stable, and monitoring confirms normal performance.

We apologise for any inconvenience caused and appreciate your patience while this issue was being resolved.
Posted Jun 12, 2026 - 13:50 UTC

Investigating

We are currently investigating an issue affecting the ServicePower EU (FSS) platform.

Affected Service: FSS EU Front-end UI
URL: https://fss.servicepower.eu/
Impact: Users may experience intermittent or complete inability to access the service via the UI. API services remain unaffected upon testing.


Our monitoring has detected a disruption, and the FSS team is actively investigating the issue.

We will provide further updates as soon as more information becomes available.
Posted Jun 12, 2026 - 13:02 UTC
This incident affected: Dispatch-EU (Dispatch-EU - FrontEnd).