ServiceDispatch API – Intermittent Webservice Issues

Incident Report for ServicePower

Resolved

This incident has been resolved.
Posted Jan 12, 2026 - 17:31 UTC

Investigating

We are currently experiencing intermittent timeouts across our Webservices.

Our on-call team is actively investigating the issue and working on a resolution as a top priority.

We expect progress within the next 30–60 minutes and will provide another update here once we have more information or full restoration.

All other systems remain operational.

Thank you for your patience while we address this.
Posted Jan 12, 2026 - 16:02 UTC
This incident affected: Dispatch-US (Dispatch-US - Application Services).