Service Availability Notice – Mobile Access Degraded Performance

Incident Report for ServicePower

Resolved

This incident is now resolved. We are still working with some clients to address some data issues caused by the outage but the outage itself has now been resolved.
Posted Apr 22, 2025 - 16:30 UTC

Investigating

We aware of a Mobile Access outage and are continuing to investigate. During this time, you may see Degraded Performance with the application. We will continue to investigate and will provide more updates as they come up.
Posted Apr 22, 2025 - 14:23 UTC