We’re pleased to confirm that all ServicePower services have remained fully operational and stable for over 36 hours following the cloud provider outage on October 20, 2025.
Recovery was observed at 5:40 AM EST on 20/10, and since then, our teams have been actively monitoring all impacted systems. No new issues or incidents have been reported during this period.
As of now, the incident has been officially marked as resolved.
Posted Oct 22, 2025 - 07:58 UTC
Update
All services remain fully operational following the earlier outage experienced by our cloud provider. Since recovery was observed, we have continued to see stable performance across all systems with no new issues reported.
Our teams are continuing to monitor the environment to ensure ongoing stability and performance closely.
If you observe any data failures or anomalies, please resend the affected data to ensure successful processing and consistency across systems.
We will provide further updates should there be any changes. Thank you for your continued patience and understanding.
Posted Oct 20, 2025 - 12:51 UTC
Monitoring
Dear Customer,
Earlier today, our cloud provider experienced a significant outage that impacted our systems beginning at 3:11 AM EST. During this time, you may have been unable to access certain services.
We can confirm that the third-party issue is showing strong signs of recovery, and we are continuing to observe positive improvements across all systems. As of 5:40 AM EST, most services are operating normally, though our teams remain closely engaged while full stability is confirmed.
We recommend that you:
- Verify that your systems are operating as expected. - Review and, if necessary, rerun any scheduled or maintenance jobs that may have failed during the outage.
Should you experience any remaining issues or irregularities, please contact us through your usual communication channels, and our support team will prioritise your request.
We sincerely apologise for any inconvenience caused and appreciate your patience while we worked to restore service stability.
Posted Oct 20, 2025 - 09:55 UTC
This incident affected: Scheduling-US (Gantt-US, Sched-US - BrokerSVC), Mobile Access-US (Mobile Access-US - FrontEnd, Mobile Access-US - Application Services, Mobile Access-US - Broker Service), Customer Self-Service -US (Customer Self-Service-US - FrontEnd, Customer Self-Service-US - Application Services), Work Order Management-US (Work Order Management-US - FrontEnd, Work Order Management-US - Application Services), Dispatch-US (Dispatch-US - BrokerSVC), and ServiceHub-US.