The scheduled release has been cancelled. Mobile Access US will remain on version 5.8.0 for the time being.
We will issue a new maintenance notification once the release has been rescheduled.
Thank you for your understanding.
Posted Oct 16, 2025 - 15:39 UTC
Completed
The scheduled maintenance has been completed.
Posted Oct 09, 2025 - 05:00 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 09, 2025 - 04:00 UTC
Update
NEW DATE: 10/16/2025
Work is planned to Upgrade Mobile Access US to version 5.9.0.
During this time the below components will be inaccessible or fail to load as expected.
• Mobile Access GUI (Nexus) • Mobile Access API ((integrations) • Mobile Access Client
ServiceBroker application will also be unavailable during the upgrade.
Should users utilizing the web application experience any issues after the scheduled work, we recommend clearing the browser cache and re-initializing the application. If utilizing the Mobile Access web application from a Home Screen icon: 1. Clear browser cache (alltime) 2. Delete the Mobile Access icon from home screen. 3. Launch application and readd icon to home screen.
This release is primarily focused on bug fixes to the Mobile Access mobile application and support for ServicePower HUB, therefore no release notes are available.
The Mobile Access US Upgrade to version 5.9.0 has been postponed until further notice. We will provide a new date/time as soon as it has been determined. Thank you for your understanding.
Posted Oct 08, 2025 - 14:26 UTC
Scheduled
Work is planned to Upgrade Mobile Access US to version 5.9.0.
During this time the below components will be inaccessible or fail to load as expected.
• Mobile Access GUI (Nexus) • Mobile Access API ((integrations) • Mobile Access Client
ServiceBroker application will also be unavailable during the upgrade.
Should users utilizing the web application experience any issues after the scheduled work, we recommend clearing the browser cache and re-initializing the application. If utilizing the Mobile Access web application from a Home Screen icon: 1. Clear browser cache (alltime) 2. Delete the Mobile Access icon from home screen. 3. Launch application and readd icon to home screen.
This release is primarily focused on bug fixes to the Mobile Access mobile application and support for ServicePower HUB, therefore no release notes are available.