Dispatch/Contractor Reimbursement - US FTP Server Intermittent Issues

Incident Report for ServicePower

Postmortem

ServicePower RCA Reference: RCA-203

ServicePower Applications Impacted: Contractor Reimbursement, Dispatch

Incident Date(s): 8/1/2025-8/15/2025

Root Cause Analysis

Problem statement

Between August 1 and August 15, 2025, ServicePower identified an issue with our US FTP server that may have impacted certain file transfers related to Contractor Reimbursement and Dispatch information. During this time, some file transfers experienced intermittent failures without generating error notifications, which may have caused certain files to go unprocessed.

Root Cause

While the exact underlying cause could not be confirmed, our investigation indicates the issue was most likely related to intermittent network instability affecting the FTP environment. Because error notifications were not triggered, these failures were not immediately visible.

Remediation Actions

As of August 15, 2025, the issue has been resolved. ServicePower implemented improvements to network resources, and all file transfers are now processing successfully.

  • ServicePower has added enhanced monitoring to proactively detect and alert us to any transfer failures.
  • Our technical teams are building long-term improvements to further strengthen system performance and stability.
  • We will continue to provide updates on additional safeguards as they are implemented.
Posted Sep 10, 2025 - 14:33 UTC

Resolved

This incident has been resolved.
Posted Sep 10, 2025 - 14:29 UTC

Monitoring

We want to make you aware of an issue we recently identified with our US FTP server that may have impacted certain file transfers. This issue only affects Contractor Reimbursement and Dispatch information specifically sent to or from ServicePower via the US FTP server.

Starting in August 2025, some file transfers experienced intermittent failures that did not generate an error notification. Because of this, some files may not have been processed as expected. The issue is no longer occurring as of August 15, 2025. ServicePower has implemented additional monitoring to ensure it does not occur going forward. Our technical teams are also working on a long-term solution to fully prevent this from happening in the future.

We are currently preparing an RCA that will be delivered as soon as the analysis is complete. In the meantime, we kindly ask that you review your records and contact Support for any assistance with reprocessing any necessary records that were transmitted via the US FTP server between August 1 and August 15. Unfortunately, ServicePower is unable to identify and reprocess those files on your behalf. Our Support team is ready and happy to assist with obtaining any reporting from ServicePower that may assist in the reconciliation process.

Thank you for your understanding and partnership as we work quickly to resolve this matter, and we apologize for any inconvenience this has caused.

Kind regards,
ServicePower Team

If you require any further assistance, please navigate to the URL below for contact details
https://www.servicepower.com/contact-us
Posted Sep 04, 2025 - 17:47 UTC
This incident affected: Dispatch-US (Dispatch-US - FrontEnd, Dispatch-US - Application Services) and Contractor Reimbursement-US (Contractor Reimbursement-US - FrontEnd, Contractor Reimbursement-US - Application Services).