Contractor Reimbursement - Connection issues and Latency Reported by users

Incident Report for ServicePower

Postmortem

To provide some additional context into what occurred, one of our batch processes hit an internal threshold that the system was not designed to exceed. When the process attempted to generate additional records, it triggered unexpected behavior that led to elevated CPU usage and overall system degradation. We are implementing a code fix to prevent this from happening again.

 

Thanks again, and we apologize for the inconvenience this caused today.

Posted Dec 01, 2025 - 21:32 UTC

Resolved

This incident has been resolved.
Posted Dec 01, 2025 - 19:52 UTC

Update

We are continuing to investigate this issue exhausting all of our resources and treating as a critical priority 1 issue. We will continue to review with high priority and provide updates as they come up.
Posted Dec 01, 2025 - 18:28 UTC

Investigating

We are actively looking into Contractor Reimbursement connectivity and latency reports in production. We are reviewing this with high priority and will provide updates as we investigate.
Posted Dec 01, 2025 - 17:17 UTC
This incident affected: Contractor Reimbursement-US (Contractor Reimbursement-US - FrontEnd, Contractor Reimbursement-US - Application Services).