Dispatch & Contractor Reimbursement - Missing Dispatches

Incident Report for ServicePower

Resolved

This incident has been resolved.
Posted Jun 03, 2026 - 20:03 UTC

Investigating

We are currently investigating reports of missing dispatches in Contractor Reimbursement affecting multiple Servicers.
Posted Jun 03, 2026 - 17:53 UTC
This incident affected: Dispatch-US (Dispatch-US - FrontEnd) and Contractor Reimbursement-US (Contractor Reimbursement-US - FrontEnd).