ServicePower Hub Incident 8/21/2026 - 8/25/2026

Incident Report for ServicePower

Postmortem

Clients using Dispatch, Contractor Reimbursement, and/or DOMO, may notice call status discrepancies in generated reports for this time period. The incident also may have caused inconsistencies in dispatch status history in Contractor Reimbursement, Dispatch, and the HUB user interface. Please see the Root Cause Analysis below for more details.

Problem statement
Between August 21, 2026 and August 25, 2026, some users in ServicePower Hub reported that work orders were in an incorrect status. Work orders that had already been closed, in some cases, appeared as open or in another status, which caused confusion for affected Servicers and disrupted their internal processes.

Root Cause
The issue was caused by an internal database migration executed on August 20, 2026, to improve performance and efficiency. During this migration, some work order status updates made between July 20, 2026 and August 21, 2026 were not synchronized to the new database, meaning affected Servicers did not see the most current status for those work orders.

Remediation Actions
ServicePower's technical teams identified the root cause and began a corrective database migration on August 24, 2026, which completed and was validated the same evening. Additional validation was performed on the morning of August 25, confirming that all affected work order statuses had been corrected.

ServicePower is enhancing its database migration protocol, including a more comprehensive migration plan, stakeholder review, and expanded testing to detect issues such as this prior to the migration, in the future.

Please contact our Support team for any questions or concerns regarding this incident. Navigate to the URL below for Support contact details Contact Us | ServicePower.

Posted Aug 28, 2026 - 18:40 UTC

Resolved

Between August 21 and August 25, 2026, some Servicers using the ServicePower Hub experienced incorrect work order statuses. Work orders that had already been closed, in some cases, appeared as open or in another status, which caused confusion for affected Servicers and disrupted their internal processes.

This incident was resolved on the night of August 24, 2026, and was validated the morning of August 25, 2026.

A post-mortem will be published and sent to clients for review, with details on what they can expect in their reporting as a result of this incident.
Posted Aug 27, 2026 - 22:49 UTC
This incident affected: Dispatch-US (Dispatch-US - FrontEnd) and Contractor Reimbursement-US (Contractor Reimbursement-US - FrontEnd).