Contractor Reimbursement System Outage Notification

Incident Report for ServicePower

Resolved

This incident has been resolved.
Posted Jun 15, 2025 - 12:58 UTC

Update

We are continuing to investigate this issue.
Posted Jun 15, 2025 - 12:37 UTC

Update

We are continuing to investigate this issue.
Posted Jun 15, 2025 - 10:01 UTC

Investigating

Dear Customers,

We are aware of issues affecting access to the Contractor Reimbursement system user interface at https://claimworks.servicepower.com/. Our team is actively investigating the problem, and we apologize for the inconvenience this may cause. We appreciate your patience while we work to resolve the issue as quickly as possible.

Thank you
Posted Jun 15, 2025 - 09:08 UTC
This incident affected: Contractor Reimbursement-US (Contractor Reimbursement-US - FrontEnd, Contractor Reimbursement-US - Application Services).