Mobile Access Degradation

Incident Report for ServicePower

Resolved

This incident has been resolved.
Posted Apr 15, 2025 - 15:02 UTC

Investigating

ServicePower is actively investigating an issue affecting the Mobile Access client, which may be causing difficulties with logging in or receiving data. Our technical team is working diligently to identify the root cause and restore full functionality as quickly as possible.
Posted Apr 15, 2025 - 13:55 UTC
This incident affected: Mobile Access-US (Mobile Access-US - FrontEnd).