Dispatch US Staging Environment Unavailable

Incident Report for ServicePower

Resolved

This incident has been resolved.
Posted Feb 06, 2026 - 22:52 UTC

Investigating

Our Dispatch Staging Environment database is currently unavailable. Our developers are investigating this with urgency to restore function as quickly as possible. Thank you for your patience, and we will keep this page updated as soon as we have more information.

Please note that the Dispatch Production environment is fully functional and not affected.
Posted Feb 06, 2026 - 22:10 UTC
This incident affected: Dispatch-US (Dispatch-US - FrontEnd).